Project

General

Profile

Unterstützte PHP-Versionen

Shopversion Anmerkung PHP min. Version PHP max. Version
vor oder gleich GX2 2.0.12.x ohne VRRL TCPdfCreator 5.1.2 5.3.x
vor oder gleich GX2 2.0.12.x mit VRRL TCPdfCreator 5.2.x 5.3.x
GX2 2.0.13-2.0.18 ohne VRRL TCPdfCreator 5.1.2 5.4.x
GX2 2.0.13-2.0.18 mit VRRL TCPdfCreator 5.2.x 5.4.x
GX2 2.1.0.0-2.2.x.x 5.3.x 5.5.x
GX2 2.3.x.x-2.4.x.x 5.3.x 5.6.x
GX2 2.5.x.x-2.7.x.x 5.4.x 5.6.x
GX3 3.0.x.x 5.4.x 5.6.x
GX3 3.1.x.x-3.4.x.x 5.4.x 7.0.x
GX3 3.5.x.x-3.6.x.x 5.4.x 7.1.x
GX3 3.7.x.x-3.8.x.x 5.5.x 7.1.x
GX3 3.9.x.x-3.10.x.x 5.5.x 7.2.x
GX3 3.11.x.x-3.12.x.x 5.6.x 7.2.x
GX3 3.13.x.x-3.14.x.x PHP 7.x empfohlen 5.6.x 7.3.x
GX3/4 3.15.x.x-4.0.x.x 7.1.x 7.3.x
GX4 4.1.x.x-4.6.x.x 7.2.x 7.4.x
GX4 4.7.x.x oder später 7.4.x 8.1.x

Die von uns jeweils empfohlene Konfiguration ist immer die maximal vom Shop unterstütze PHP-Version.

Bitte beachtet, dass alle Versionen von PHP kleiner als PHP 7.3 durch das PHP-Entwicklerteam nicht mehr mit Sicherheitsupdates versorgt werden und somit potenziell Sicherheitslücken aufweisen können und zum Teil auch bekannte Sicherheitslücken besitzen, die durch den Shop als darauf aufsetzende Plattform nicht schließbar sind. Der Shop kann immer nur so sicher sein, wie die Serverplattform darunter.

Hier kann eingesehen werden, wie lange eine PHP-Version mit Sicherheitsupdates versorgt wird:
https://www.php.net/supported-versions.php

Für die fehlerfreie Funktion der Software sollten folgende PHP Extensions auf dem Webspace installiert sein:

  • json
  • curl
  • dom
  • filter
  • gd
  • intl
  • libxml
  • mbstring
  • soap
  • xml
  • zip
  • zlib
Add picture from clipboard (Maximum size: 5 MB)