Project

General

Profile

GX-Bug #66593

Gambio Updater nicht PHP 5.6 kompatibel, sodass statt des Hinweises auf eine neue PHP Version eine Fehlermeldung angezeigt wird

Added by Till Tepelmann 4 months ago. Updated 4 months ago.

Status:
Erledigt
Priority:
Sofort
Assigned To:
Category:
Updater
Target version:
% Done:

0%

Estimated time:
Steps to reproduce:
Betroffene Versionen:
4.0.0.0, 4.0.0.1, 4.1.1.0 beta4
Release Notes Langtext:

Der Updater und Installer zeigt jetzt zuverlässig eine Meldung, wenn die PHP-Version zu niedrig ist

Story points-Velocity based estimate-

Description

Gambio Updater nicht PHP 5.6 kompatibel, sodass statt des Hinweises auf eine neue PHP Version eine Fehlermeldung angezeigt wird.

Der Updater muss unter jeder PHP Version immer aufrufbar sein und die entsprechende Hinweismeldung anzeigen, dass man PHP 7.1 oder höher benötigt um das Update ausführen zu können.

Gambio Updater is not PHP 5.6 compatible, so instead of the reference to a new PHP version an error message is displayed.

The updater must always be accessible under any PHP version and must display a message that PHP 7.1 or higher is required to run the update.

Parse error: syntax error, unexpected '?' in /system/core/caching/CacheControl.inc.php on line 170
PARSE ERROR(4): "syntax error, unexpected '?'"


Related issues

Precedes GX-Entwicklung - GX-Task #66634: Copy the CacheControl to the updater to decouple the updater from the shopGemeldet

Actions
Copied to GX-Entwicklung - GX-Bug #66694: Gambio Updater nicht PHP 5.6 kompatibel, sodass statt des Hinweises auf eine neue PHP Version eine Fehlermeldung angezeigt wirdErledigt

Actions

History

#1

Updated by Ulrich Wenk 4 months ago

  • Status changed from Gemeldet to Anerkannt
#2

Updated by Till Tepelmann 4 months ago

  • Tags set to stable
#3

Updated by Daniel Wu 4 months ago

Should be changed directly in the CacheControl

#4

Updated by Daniel Wu 4 months ago

  • Precedes GX-Task #66634: Copy the CacheControl to the updater to decouple the updater from the shop added
#5

Updated by Marvin Muxfeld 4 months ago

  • Status changed from Anerkannt to In Bearbeitung
  • Assigned To changed from Core-Entwickler to Marvin Muxfeld
#6

Updated by Marvin Muxfeld 4 months ago

The mentioned error was solved by the commit ebaa4d96d4a61da7653f93ee50f6a56c68f107b4

#7

Updated by Moritz Bunjes 4 months ago

  • Assigned To changed from Marvin Muxfeld to Moritz Bunjes
#8

Updated by Moritz Bunjes 4 months ago

  • Tags deleted (stable)
  • Status changed from In Bearbeitung to Testing
  • Assigned To changed from Moritz Bunjes to Core-Entwickler
  • Target version changed from SP-Candidates to 4.1.1.0 RC1
  • Release Notes Langtext updated (diff)
#9

Updated by Moritz Bunjes 4 months ago

  • Copied to GX-Bug #66694: Gambio Updater nicht PHP 5.6 kompatibel, sodass statt des Hinweises auf eine neue PHP Version eine Fehlermeldung angezeigt wird added
#10

Updated by Moritz Bunjes 4 months ago

Marvin Muxfeld schrieb:

The mentioned error was solved by the commit ebaa4d96d4a61da7653f93ee50f6a56c68f107b4

This commit only solves it for GX 4.0 and it isn't that stable. I implemented an independent solution.

#11

Updated by Ahmed Hamouda 4 months ago

  • Status changed from Testing to Erledigt
#12

Updated by Ahmed Hamouda 4 months ago

  • Assigned To changed from Core-Entwickler to Ahmed Hamouda
#13

Updated by Moritz Bunjes 4 months ago

  • Release Notes Langtext updated (diff)
#14

Updated by Moritz Bunjes 4 months ago

The installer was also considered for this fix

Also available in: Atom PDF

Add picture from clipboard (Maximum size: 5 MB)